Gazebo | Ignition | Community
Ask Your Question

"gzserver: symbol lookup error" when launching Gazebo in Ubuntu 16.04

asked 2018-04-29 09:49:17 -0600

gianluca gravatar image

I have just installed ROS kinetic and Gazebo 7.12.0 in Ubuntu 16.04. When I launch gazebo from terminal I get the following error:

gzserver: symbol lookup error: /usr/lib/x86_64-linux-gnu/ undefined symbol: _ZN8ignition4math15SemanticVersionC1ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

and Gazebo won't start.

The strange thing is that if I launch the Turtlebot simulation roslaunch turtlebot_gazebo turtlebot_world.launch Gazebo starts correctly without raising any error. Any idea on why this is happening?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-06-11 12:12:21 -0600

I solved a similar problem using the solution here - Check if that solves it.

edit flag offensive delete link more


hi @parthchopra, I dont know why but I cant access the link which you mentioned. Could you provide another reference on how did you solved this problem? Thanks.

rajshah1993 gravatar imagerajshah1993 ( 2020-05-31 17:46:07 -0600 )edit

Question Tools



Asked: 2018-04-29 09:49:17 -0600

Seen: 10,522 times

Last updated: Apr 29 '18