Can't load any mesh into gazebo

asked 2018-04-29 16:57:49 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everyone,

i was working on a model in which visual and collision geometry are defined through a .stl file(mesh). Everything was all right since today. Gazebo doesn't load anymore its mesh file. I also noticed that all the models that i can download from bitbucket have the same problem, except that for the ones which are provived with a png texture. I thought it might be a GPU problem, so i reinstalled the video drivers but nothing changed. And of course the terminal doesn't say nothing about errors or issues. Don't really know what to do :/

edit retag flag offensive close merge delete


What Gazebo version are you using? What operating system? Can you run Gazebo in verbose mode to see if any errors show up?

chapulina gravatar imagechapulina ( 2018-04-29 20:25:47 -0500 )edit

I'm using Gazebo 9.0.0 on Ubuntu 16.04 LTS. I tried to open gazebo in verbose and it says: [Err] [] File or path does not exist[""] [Err] [] No mesh specified I checked the path and it was right(relative). So i just tried to use an absolute path and it worked!!! I don't know why it's stopped working, everything was ok with the relative path until yesterday. Thank you very much for your tip :)

Lo11o2 gravatar imageLo11o2 ( 2018-04-30 06:14:03 -0500 )edit

Glad to hear you figured it out! Just curious, what was the path relative to? To the `model.sdf` file?

chapulina gravatar imagechapulina ( 2018-04-30 14:35:00 -0500 )edit

I had this in collision and visual tags: <geometry> <mesh> <uri>file://meshes/chassis.stl</uri> </mesh> </geometry> In the model directory i have: model.sdf, model.config and the directory meshes. It just stopped working, i don't know why. Never touched that part since the first time i loaded the model on Gazebo.

Lo11o2 gravatar imageLo11o2 ( 2018-04-30 15:20:56 -0500 )edit