Gazebo crash, core dumped, likely graphics card driver incompatibility [closed]

asked 2013-03-19 10:22:04 -0500

Shanker Keshavdas gravatar image

updated 2013-03-19 10:23:41 -0500

Hi all,

I have installed Gazebo v1.5 following all instructions. I am running Ubuntu 64-bit 12.04. My question is identical to the question asked by @treanorj here .

The reason that I am posting this as a new question is that

  1. The original question is different and the question referred to is asked in the comment section.
  2. I have some follow-up problems not addressed there

When I run 'gdb gzserver' and 'gdb gzclient' in different terminals, I get a segmentation fault in the gzclient terminal. Upon bt, the output is :

#0  0x00007fffe17d3307 in ?? () from /usr/lib/fglrx/dri/
#1  0x00007fffe184910e in ?? () from /usr/lib/fglrx/dri/
#2  0x00007fffe1849449 in ?? () from /usr/lib/fglrx/dri/
#3  0x00007fffe0d5c421 in ?? () from /usr/lib/fglrx/dri/
#4  0x00007fffe0c690b8 in ?? () from /usr/lib/fglrx/dri/
#5  0x00007fffe0dc85b7 in ?? () from /usr/lib/fglrx/dri/
#6  0x00007fffe10e883d in ?? () from /usr/lib/fglrx/dri/
#7  0x00007fffd1338a20 in Ogre::GLRenderSystem::bindGpuProgram(Ogre::GpuProgram*) () from     /usr/lib/x86_64-linux-gnu/OGRE-1.7.4/
#8  0x00007ffff1ca05e5 in Ogre::SceneManager::_setPass(Ogre::Pass const*, bool, bool) () from /usr/lib/x86_64-linux-gnu/
#9  0x00007ffff1c9b269 in Ogre::SceneManager::SceneMgrQueuedRenderableVisitor::visit(Ogre::RenderablePass*) ()
   from /usr/lib/x86_64-linux-gnu/
#10 0x00007ffff1c52d59 in Ogre::QueuedRenderableCollection::acceptVisitorDescending(Ogre::QueuedRenderableVisitor*) const ()
   from /usr/lib/x86_64-linux-gnu/
#11 0x00007ffff1c52e01 in Ogre::QueuedRenderableCollection::acceptVisitor(Ogre::QueuedRenderableVisitor*, Ogre::QueuedRenderableCollection::OrganisationMode) const () from /usr/lib/x86_64-linux-gnu/
#12 0x00007ffff1c9b7bc in Ogre::SceneManager::renderBasicQueueGroupObjects(Ogre::RenderQueueGroup*, Ogre::QueuedRenderableCollection::OrganisationMode) ()
   from /usr/lib/x86_64-linux-gnu/
---Type <return> to continue, or q <return> to quit---
#13 0x00007ffff1c9a9e7 in Ogre::SceneManager::renderVisibleObjectsDefaultSequence() () from /usr/lib/x86_64-linux-gnu/
#14 0x00007ffff1c9f184 in Ogre::SceneManager::_renderScene(Ogre::Camera*, Ogre::Viewport*, bool) () from /usr/lib/x86_64-linux-gnu/
#15 0x00007ffff1b066ec in Ogre::Camera::_renderScene(Ogre::Viewport*, bool) ()
   from /usr/lib/x86_64-linux-gnu/
#16 0x00007ffff1c6b9f8 in Ogre::RenderTarget::_updateViewport(Ogre::Viewport*, bool) () from /usr/lib/x86_64-linux-gnu/
#17 0x00007ffff1c6b91b in Ogre::RenderTarget::_updateAutoUpdatedViewports(bool)
() from /usr/lib/x86_64-linux-gnu/
#18 0x00007ffff1c6b3be in Ogre::RenderTarget::updateImpl() ()
   from /usr/lib/x86_64-linux-gnu/
#19 0x00007ffff1c6b95c in Ogre::RenderTarget::update(bool) ()
   from /usr/lib/x86_64-linux-gnu/
#20 0x00007ffff72e0ac8 in gazebo::rendering::Camera::RenderImpl() ()
   from /usr/lib/
#21 0x00007ffff72e0b49 in gazebo::rendering::Camera::Render() ()
   from /usr/lib/
#22 0x00000000004c5383 in gazebo::gui::GLWidget::paintEvent(QPaintEvent*) ()
#23 0x00007ffff645f0f6 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/
#24 0x00007ffff640e894 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib/x86_64-linux-gnu/
---Type <return> to continue, or q <return> to quit---
#25 0x00007ffff6413713 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/
#26 0x00007ffff5eebe9c in QCoreApplication::notifyInternal(QObject*, QEvent*)
() from /usr/lib/x86_64-linux-gnu/ ...
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2013-07-23 18:24:40.289703


i have same error like you, my laptop is lenovo R500 and ATI Mobility Radeon HD 3400 Series. just see >> i do n't find any solution, do0 you have any idea?

Mohsen Hk gravatar imageMohsen Hk ( 2013-03-19 19:28:16 -0500 )edit

@mohsen-hk Yes, your problem seems very similar, if not identical. Initially I found it hard to believe that Gazebo which is quite respected does not work with certain graphic card drivers (I know it's openGL). My question was whether anything else could be causing the problem. If not, does anybody know where to find an open source driver?

Shanker Keshavdas gravatar imageShanker Keshavdas ( 2013-03-20 03:50:58 -0500 )edit

yup... colud you help or do you have any solution to for my problem? i think i wanna open source driver to0

Mohsen Hk gravatar imageMohsen Hk ( 2013-03-20 10:36:12 -0500 )edit

i find solution! just see my link upon!

Mohsen Hk gravatar imageMohsen Hk ( 2013-03-20 11:48:35 -0500 )edit