Gazebo | Ignition | Community
Ask Your Question
1

heigthmaps slow down simulation

asked 2018-05-30 02:56:12 -0600

Mansan gravatar image

Im working on a proyect, and Im using heigthmaps models. When I add them to the simulatoin, Gazebo slow down a lot and even freezes. I have also realized that , the higher I set the max heigth in the sdf file , the slower the simulation is. Does anyone know why this happends?Is there any way to solve it? Im using gazebo 7 in Ubuntu 16.04.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-30 12:03:07 -0600

chapulina gravatar image
  1. Can you try running gzserver without gzclient, does the problem still happen? You can monitor the real time factor with the command gz stats

  2. If the problem doesn't happen, you can try setting the level of detail for heightmaps for gzclient by adding this to ~/gui.ini:

    [heightmap]
    lod=3
    
  3. You could also try reducing the definition of your heightmap

edit flag offensive delete link more

Comments

Thanks!This helped me a lot! Running gzserver doesn't slow down the simulation, and most of the time I dont need to use the client, so it is at least a partial solution.

Mansan gravatar imageMansan ( 2018-06-14 03:48:09 -0600 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-05-30 02:56:12 -0600

Seen: 177 times

Last updated: May 30 '18