Gazebo | Ignition | Community
Ask Your Question

Upgraded DRC Simulator, and now roslaunch UI fails to load for atlas.

asked 2013-03-19 23:53:07 -0600

unknown_entity1 gravatar image

Upgraded DRC Simulator, and now roslaunch UI fails to load for atlas. Anyone know the cause? - Thanks, Aaron

gazebo: symbol lookup error: /usr/lib/drcsim-2.1/plugins/ undefined symbol: _ZN6gazebo9transport9PublisherC1ERKSsS3j Warning [] escalating to SIGKILL on client [gazebo-2] process has finished cleanly

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-03-20 12:22:51 -0600

gerkey gravatar image

Sounds like a version mismatch between drcsim and gazebo. In particular, you probably have drcsim 2.1.x + gazebo 1.5.x, which is an unsupported configuration.

Try an update and explicit install of both, which should get you to drcsim 2.2.x + gazebo 1.5.x:

sudo apt-get update
sudo apt-get install drcsim gazebo
edit flag offensive delete link more


Didn't work, and I received the following error: gazebo: symbol lookup error: /usr/lib/drcsim-2.1/plugins/ undefined symbol: _ZN6gazebo9transport9PublisherC1ERKSsS3j

Error [] Connection[0] Closed during Read terminate called after throwing an instance of 'boost::system::system_error' what(): Connection reset by peer [gazebo-2] process has finished cleanly

unknown_entity1 gravatar imageunknown_entity1 ( 2013-03-20 23:29:04 -0600 )edit

The following was the output from the sudo apt-get.. sudo apt-get install drcsim gazebo Reading package lists... Done Building dependency tree
Reading state information... Done drcsim is already the newest version. gazebo is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.

unknown_entity1 gravatar imageunknown_entity1 ( 2013-03-20 23:30:44 -0600 )edit

I wonder if the installer is failing to install because I don't have an AMD64 for the 64-bit package for the Boston Dynamics addition?

unknown_entity1 gravatar imageunknown_entity1 ( 2013-03-20 23:32:22 -0600 )edit

Oh, that would definitely do it. In that case, apt-get will refuse to upgrade your drcsim to 2.2.0, leaving you with an incompatible version combination. You should either move to a 64-bit machine or build drcsim 2.2.0 from source.

gerkey gravatar imagegerkey ( 2013-03-21 00:06:36 -0600 )edit

Having exactly the same problem as this poster - I can't update from drcsim-2.1, and now I have gazebo-1.5 with it and nothing's working. We run an intel chip, that doesn't seem to be the problem. What would cause the apt-get update to not detect that 2.2 is available? My keys seem correct, nothing else has change with my installer lists.

DRC_Justin gravatar imageDRC_Justin ( 2013-03-21 13:49:28 -0600 )edit

@DRC_Justin: are you running on 32-bit or 64-bit? Try uname -m. If it returns x86_64 or amd64, you're on 64-bit. If it returns something else (probably x86), you're on 32-bit.

gerkey gravatar imagegerkey ( 2013-03-21 14:48:53 -0600 )edit

@gerkey: We are running 32 bit. It returned i686. What should we be running?

DRC_Justin gravatar imageDRC_Justin ( 2013-03-21 14:54:00 -0600 )edit

answered 2013-03-21 17:10:36 -0600

gerkey gravatar image

You need a 64-bit machine. Pretty much all computers are actually 64-bit these days, so it's probably a matter of reinstalling Ubuntu, this time in 64-bit.

edit flag offensive delete link more


LOL, I run celeron processor on my laptop. My initial premise was this would be the perfect platform to write a highly efficient, high performance intelligent agent for a robotic controller with low power consumption requirements. I can't afford to run out and buy a new computer, and I don't work for, or attend a university so a computer lab is out of the question. Do any other alternatives exist? If I compile 2.2 I was under the impression I still can't use the bostondynamics module?

unknown_entity1 gravatar imageunknown_entity1 ( 2013-03-21 21:56:15 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2013-03-19 23:53:07 -0600

Seen: 410 times

Last updated: Mar 21 '13