Iterative training problems

asked 2018-07-12 03:19:51 -0500

Veztak gravatar image

Hi gazebo-community, as i am trying to implement a neuroevolutionary method using gazebo as a simulator i am running into the same problem for quite some weeks now:

When trying to reset the simulation / the robot to always have the same starting positions everything works fine from a visual point of view. The robot "jumps" back into its original position when i call ->reset_simulation / world. Still i always get different results even tho i use the same pattern every iteration. I read some questions on this forum regarding the same problem, but none of those come up with a working solution (at least for me).

I tried deleting and respawning the model, which leaks memory and causes a segfault after some time. I tried calling different resets, resetting via commandline and also via ROS topic.

I read one answert stating this kind of iterative training is not possible in gazebo. Did this change lately or is my approach generally wrong?

Thanks in advance

edit retag flag offensive close merge delete