¿How can I improve the performance of my SDF Model that is slipering and vibrating?

asked 2018-07-23 11:00:36 -0500

Saimon gravatar image

Hi to everyone ! I have two problems for which I need your help =) !!

I am working with Gazebo 7 some months ago and I created a SDF Model to represent a mobile robot, with 6 wheels and 7 cameras, with three plugin to control the wheels movement, width of the model and teleoperation respectively.

The first problem that I have is from the beginning of the creation of the model. When it is stop (not moving), picture 1, after some seconds the wheels begun to slide in consequence move or rotate the model as if there wasn’t friction, even if is defined the value of friction in the wheels (mu = 0.9,mu2 =0.8, slip1= 0, slip2=0) and also the collision, inertia and mass is define like you can see in pictures 2, 3, 4 and 5. Someone knows how can I improve this situation? I tried to improve this situation trying different values of mu, slip, inertia and collision but the problems continue.

image description image description

Picture 1

image description

Picture 2

image description

Picture 3

image description

Picture 4

image description

Picture 5

The second problem is about the cameras. When I installed the cameras the model start to vibrating , I am thinking that probably I am not using the properties of Gazebo and SDF correctly to define the inertia of the cameras picture 6, because as you can see in picture 7 and 8 the inertia is too big for the model, but this is the value of inertia that I found wrote in the model SDF of the camera ASUS XTION that I am using. I was trying to set a value of inertia more small and in consequence more real for the size of the model, but when I did this, the model begun to fly. Does someone know how can I have a completely stable model or what I am not considering? 

image description

Piture 6

image description

Picture 7

image description


I hope someone can tell me what I am doing wrong.

Thank you in advance for your help and ideas and a friendly hug for the community !

edit retag flag offensive close merge delete


For your first problem, you can try to increase the iters value http://gazebosim.org/tutorials?tut=preset_manager&cat=physics or change the max step size http://answers.gazebosim.org/question/2477/what-does-update-rate-control/

GuillaumeB gravatar imageGuillaumeB ( 2018-07-24 09:21:05 -0500 )edit

Hi GuillaumeB !! Thank you for your suggestion , I didnt think in this before !! I'll check the "Manage physics profiles" and I hope to have good result ! I'll keep you informed !

Saimon gravatar imageSaimon ( 2018-07-26 02:58:07 -0500 )edit

Finally I could improve the performance of the model, I started to check and modify different parameter of the ODE PHYSICS ENGINE and even the vibration stopped =D !! THnak you so much four your help !!

Saimon gravatar imageSaimon ( 2018-07-26 05:31:03 -0500 )edit