Gazebo | Ignition | Community
Ask Your Question

Invalid use of template name 'ignition::math::v5::Box'

asked 2018-08-27 12:46:32 -0500

eraserpencil gravatar image

I am on Ubuntu 16.04, Kernel 4.17

I have successfully build from source ign-cmake, ign-common1, ign-fuel-tools1, ign-math4, ign-msgs, ign-msgs, ign-transport, sdformat6.

Whilst making gazebo from this page Gazebo::Install from Source, I ran into the following errors.

In file included from /home/ryan/Documents/source/gazebo/gazebo/rendering/
/home/ryan/Documents/source/gazebo/gazebo/rendering/MovableText.hh:217:15: error: invalid use of template-name ‘ignition::math::v5::Box’ without an argument list
   public: ignition::math::Box AABB();
In file included from /home/ryan/Documents/source/gazebo/gazebo/rendering/Scene.hh:39:0,
             from /home/ryan/Documents/source/gazebo/gazebo/rendering/
/home/ryan/Documents/source/gazebo/gazebo/rendering/Visual.hh:478:15: error: invalid use of template-name ‘ignition::math::v5::Box’ without an argument list
   public: ignition::math::Box BoundingBox() const;
/home/ryan/Documents/source/gazebo/gazebo/rendering/Visual.hh:776:50: error: ‘ignition::math::Box’ is not a type
                              ignition::math::Box &_box) const;
/home/ryan/Documents/source/gazebo/gazebo/rendering/ In member function ‘void gazebo::rendering::ApplyWrenchVisual::UpdateTorqueVisual()’:
/home/ryan/Documents/source/gazebo/gazebo/rendering/ error: ‘class gazebo::rendering::Visual’ has no member named ‘BoundingBox’
double linkDiagonal = dPtr->parent->BoundingBox().Size().Length();
/home/ryan/Documents/source/gazebo/gazebo/rendering/ In member function ‘void gazebo::rendering::ApplyWrenchVisual::Resize()’:
/home/ryan/Documents/source/gazebo/gazebo/rendering/ error: ‘class gazebo::rendering::Visual’ has no member named ‘BoundingBox’
double linkSize = std::max(0.1, dPtr->parent->BoundingBox().Size().Length());
gazebo/rendering/CMakeFiles/gazebo_rendering.dir/build.make:62: recipe for target 'gazebo/rendering/CMakeFiles/gazebo_rendering.dir/' failed
make[2]: *** [gazebo/rendering/CMakeFiles/gazebo_rendering.dir/] Error 1
CMakeFiles/Makefile2:2599: recipe for target 'gazebo/rendering/CMakeFiles/gazebo_rendering.dir/all' failed
make[1]: *** [gazebo/rendering/CMakeFiles/gazebo_rendering.dir/all] Error 2
Makefile:162: recipe for target 'all' failed

Have tried changing ignition::math::Box to ignition::math::v5::Box, but it didnt help

Thanks for assisting.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2018-08-27 18:12:16 -0500

chapulina gravatar image

It looks like you're using ign-math5 (hence v5) instead of ign-math4. I suggest you uninstall all ign-math from your system and reinstall making sure it's version 4.

edit flag offensive delete link more


I manage to compile it, but I havent been able to launch it. I have it in /usr/local/bin/gazebo9, but I seem to be missing smtg cause it dosent launch. Was expecting a gui. Am I doing something wrong?

eraserpencil gravatar imageeraserpencil ( 2018-08-28 19:29:24 -0500 )edit

Can you add the output of `gazebo --verbose` to your question?

chapulina gravatar imagechapulina ( 2018-08-28 19:36:07 -0500 )edit

Gazebo multi-robot simulator, version 9.3.1 Copyright (C) 2012 Open Source Robotics Foundation. Released under the Apache 2 License. [Msg] Waiting for master. [Msg] Connected to gazebo master @ [Msg] Publicized address:

eraserpencil gravatar imageeraserpencil ( 2018-08-28 21:11:58 -0500 )edit

And then what happens? No GUI shows up?

chapulina gravatar imagechapulina ( 2018-08-29 10:48:19 -0500 )edit

yup! any ideas?

eraserpencil gravatar imageeraserpencil ( 2018-08-30 19:16:46 -0500 )edit

If you start `gzserver --verbose` and `gzclient --verbose` separately, do you see any errors?

chapulina gravatar imagechapulina ( 2018-08-30 19:22:03 -0500 )edit

gzclient --verbose has a segfault.

eraserpencil gravatar imageeraserpencil ( 2018-08-31 11:38:26 -0500 )edit

Can you run `gdb gzclient` and add the backtrace to your original question above?

chapulina gravatar imagechapulina ( 2018-08-31 11:55:16 -0500 )edit

I feel a new question would be more fitting. Will close this

eraserpencil gravatar imageeraserpencil ( 2018-09-01 12:41:54 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-08-27 12:46:32 -0500

Seen: 601 times

Last updated: Aug 27 '18