Gazebo crashes with exit code 139 during roslaunch if an (empty) vehicle is spawned

asked 2018-09-16 15:48:35 -0500

ray gravatar image

I'm on a lenovo y40 running ROS kinetic and gazebo 7.14 ubuntu 16.04

I'm following the ros_urdf tutorial here:

When I run roslaunch rrbot_gazebo rrbot_world.launch I see the following error:

[gazebo-1] process has died [pid 14503, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/user/catkin_ws/src/gazebo_ros_demos/rrbot_gazebo/worlds/ __name:=gazebo __log:=/home/user/.ros/log/7a3e64f4-b9ef-11e8-b6b7-34e6ad193665/gazebo-1.log]. log file: /home/user/.ros/log/7a3e64f4-b9ef-11e8-b6b7-34e6ad193665/gazebo-1*.log

One thing I have noticed that is not in other similar questions is that even when I completely blank out the urdf (or sdf) file, gazebo crashes with the same error. When I comment out this line from the launch file it works:

<node name="urdf_spawner" pkg="gazebo_ros" type="spawn_model" respawn="false" output="screen" args="-urdf -model rrbot -param robot_description"/>

Finally, the tutorial works for a friend of mine with the exact same setup save the computer which is a dell xps.

edit retag flag offensive close merge delete


Did you solve your issue in the end? I am having the same problem

desmond13 gravatar imagedesmond13 ( 2020-11-25 14:38:09 -0500 )edit