Gazebo | Ignition | Community
Ask Your Question

Floor and texture changed black?

asked 2018-09-27 03:08:01 -0600

littleghost gravatar image

updated 2018-10-13 05:01:58 -0600

I recently needed to reinstall the gazebo8 or gazebo9, but the floor changed black after installing with other functions working fine. I remember that the floor is light grey previously, but the floor and texture becomes black now.

image description

The simulation is too dark to have a clear vision.

My environment is ubuntu16.04 + ros kinetic, and I used this commands to install gazebo8/9:

sudo sh -c 'echo "deb `lsb_release -cs` main" > /etc/apt/sources.list.d/gazebo-stable.list' 
wget -O - | sudo apt-key add -
sudo apt-get update
sudo apt-get install libignition-math3 libsdformat5
sudo apt-get install gazebo8

The light is right and there is no error when I run it in verbose mode. I have reinstalled gazebo8 and gazebo9 many times, they all have black floor. I also tried to add 10 lights and it seems better, but it's too tedious. So I really don't know how to fix it.

edit retag flag offensive close merge delete


Just an idea. Is it possible that the path to your textures has changed after installation? It seems that gazebo can no longer find the texture therefor it renders it black.

kumpakri gravatar imagekumpakri ( 2018-09-27 03:47:50 -0600 )edit

Do you know the texture path or how to set it?

littleghost gravatar imagelittleghost ( 2018-09-27 09:02:31 -0600 )edit

I have my materials in usr/share/gazebo-9 folder. I don't know how to set it manually.

kumpakri gravatar imagekumpakri ( 2018-09-27 10:12:09 -0600 )edit

I can find the texture in usr/share/gazebo-8 folder too but it still black.

littleghost gravatar imagelittleghost ( 2018-09-28 04:33:45 -0600 )edit

When you open Gazebo check the "Lights" dropdown on the left menu. Maybe you're missing lighting or the lighting is too dark.

Raskkii gravatar imageRaskkii ( 2018-10-01 05:43:11 -0600 )edit

ok, but you are using gazebo-9 now, right? Can you find the textures also in usr/share/gazebo-9 folder? Maybe that is where the gazebo is looking for it.

kumpakri gravatar imagekumpakri ( 2018-10-02 02:33:52 -0600 )edit

When you run in verbose mode, do you get any warnings about missing material files?

chapulina gravatar imagechapulina ( 2018-10-02 12:06:30 -0600 )edit

"Lights", "texture" and "verbose mode" is all normal, I put a pic in answer, please check.

littleghost gravatar imagelittleghost ( 2018-10-12 06:27:28 -0600 )edit

Please remove the answer, and update the question with the picture instead ;)

chapulina gravatar imagechapulina ( 2018-10-12 09:35:24 -0600 )edit

I've got the right to upload pictures recently.

littleghost gravatar imagelittleghost ( 2018-10-13 05:02:58 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-31 10:59:37 -0600

ffusco gravatar image

I had a similar problem. I just bought a new acer PC and many programs were not "working properly" - Gazebo was one of those, with the black ground problem (actually, many colors seemed darker). From terminal, however, no problem was reported.

Long story short: the "problem" was that my nvidia GPU was not using the correct drivers. I had installed them, but they were not loaded properly (in my case this was due to the secure boot). Now that drivers are running colors look better.

edit flag offensive delete link more


I never use Nvidia GPU at all. It crashed just after I reinstall my ubuntu system.

littleghost gravatar imagelittleghost ( 2019-01-04 02:32:04 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-09-27 03:08:01 -0600

Seen: 893 times

Last updated: Oct 13 '18