Cannot install Gazebo 9 on ubuntu

asked 2018-11-03 22:13:35 -0500

sai2402 gravatar image

I ran this command

curl -sSL | sh

and it worked fine but when i run "gazebo" it is giving me this error.

gazebo: error while loading shared libraries: cannot open shared object file: No such file or directory

I've gone through all the different tutorials trying to install in various ways but quite frankly i'm confused. What's the best way to download and install gazebo and all the dependencies correctly and start some basic models on it? Thank you

edit retag flag offensive close merge delete


Have you sourced the Gazebo setup file before running it?

kumpakri gravatar imagekumpakri ( 2018-11-05 08:24:58 -0500 )edit

I just ran the first command that the directions for ubuntu said. What script should i source?

sai2402 gravatar imagesai2402 ( 2018-11-05 09:22:21 -0500 )edit

$ source /usr/share/gazebo/

kumpakri gravatar imagekumpakri ( 2018-11-05 09:24:21 -0500 )edit

I did that and then what should i run? gazebo is still not running

sai2402 gravatar imagesai2402 ( 2018-11-05 09:39:16 -0500 )edit

Are there any specific system requirements? I'm running on Ubuntu 16.04.4 and ran the one-liner installation but it isn't working.

sai2402 gravatar imagesai2402 ( 2018-11-05 10:00:49 -0500 )edit

Either you don|t have the library or you don't have correctly set the path to libraries. Refer to this answer If you can find the file on your comuter, then you have wrong paths. Otherwise you have to install the library.

kumpakri gravatar imagekumpakri ( 2018-11-05 10:07:55 -0500 )edit

man there is no /local/ folder in my install path. My main question is why does the original one liner script not work? Someone else ran it on their virtual machine and told me it worked fine.

sai2402 gravatar imagesai2402 ( 2018-11-05 11:07:53 -0500 )edit

What version of ubuntu are you running?

nkoenig gravatar imagenkoenig ( 2018-11-05 14:45:41 -0500 )edit