Gazebo | Ignition | Community
Ask Your Question

Problem compiling Plugins

asked 2018-11-23 09:59:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


i have a problem, compiling Plugins for Gazebo. I am running Gazebo version 9.5.0 in an Ubuntu 16.04 LTS. Bevore i switched to Gazebo version 9.5 i used an older Version, but I cant recall with it was. With this older version I had no problems writing and compiling Plugins.

Since the Update There is no longer an .so file after building the Plugin. I think, that it must be an error on compiler site, for the error existis even if i try to recreate the hello_world tutorialt, if i try to start the simulation, as told in the tutorial, it says that it cant find the .so file. The consol output doesen't (clearly) state an error, witch is the reason i am left clueless.

-- The C compiler identification is GNU 5.4.0 -- The CXX compiler identification is GNU 5.4.0 -- Check for working C compiler: /usr/bin/cc -- Check for working C compiler: /usr/bin/cc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") -- Checking for module 'bullet>=2.82' -- Found bullet, version 2.83 -- Found Simbody: /usr/include/simbody
-- Looking for pthread.h -- Looking for pthread.h - found -- Looking for pthread_create -- Looking for pthread_create - not found -- Looking for pthread_create in pthreads -- Looking for pthread_create in pthreads - not found -- Looking for pthread_create in pthread -- Looking for pthread_create in pthread - found -- Found Threads: TRUE
-- Boost version: 1.58.0 -- Found the following Boost libraries: -- thread -- signals -- system -- filesystem -- program_options -- regex -- iostreams -- date_time -- chrono -- atomic -- Found Protobuf: /usr/lib/x86_64-linux-gnu/
-- Boost version: 1.58.0 -- Looking for OGRE... -- OGRE_PREFIX_WATCH changed. -- Checking for module 'OGRE' -- Found OGRE, version 1.9.0 -- Found Ogre Ghadamon (1.9.0) -- Found OGRE: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_Paging... -- Found OGRE_Paging: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_Terrain... -- Found OGRE_Terrain: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_Property... -- Found OGRE_Property: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_RTShaderSystem... -- Found OGRE_RTShaderSystem: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_Volume... -- Found OGRE_Volume: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Looking for OGRE_Overlay... -- Found OGRE_Overlay: optimized;/usr/lib/x86_64-linux-gnu/;debug;/usr/lib/x86_64-linux-gnu/ -- Found Protobuf: /usr/lib/x86_64-linux-gnu/ (Required is at least version "2.3.0") -- Checking for module 'uuid' -- Found uuid, version 2.27.0 -- Found UUID: TRUE
-- Checking for module 'tinyxml2' -- Found ... (more)

edit retag flag offensive close merge delete


Where do you look for the .so file? Is it possible the new version creates the libraries somewhere else?

kumpakri gravatar imagekumpakri ( 2018-11-26 07:49:34 -0500 )edit

What is the name of the Plugin you tried to compile while getting this terminal output?

kumpakri gravatar imagekumpakri ( 2018-11-26 07:51:03 -0500 )edit

Good Day, 1) I am looking ion the created build folder. As written in the tutorial i navigate inside the build folder an call $ cmake .. In the older version the .so file appeared in the build directory. 2) I followed the instructions from the Hello_World tutorial ( ) and a self written plugin (witch compiled in the old version). Both have the same result. Do you know of a way to check if the .so file is created somewhere else? I searched the system

Delay Lama gravatar imageDelay Lama ( 2018-11-27 07:48:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-07 10:27:14 -0500

Delay Lama gravatar image

Okay, case closed. The Problem was in front of the monitor.

Thanks for helping

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-11-23 09:59:32 -0500

Seen: 345 times

Last updated: Dec 07 '18