Cant spawn robot in XACRO format

asked 2018-12-20 09:52:49 -0600

12melvin gravatar image

updated 2018-12-20 11:25:18 -0600

chapulina gravatar image


I have issues to spawn my FRANKA EMIKA robot in Gazebo. The robot model is a XACRO format.

I followed this tutorial:

At first I followed the chapter "Creating your own Gazebo ROS Package". With that everything works fine.

First I have to call the command roscore in a terminal.

Afterwards I type in a new terminal:

. ~/catkin_ws/devel/setup.bash
roslaunch franka_gazebo franka.launch

The gas station shows up fine as shown in the tutorial.

Afterwards I followed the chapter "Using roslaunch to spawn URDF robots" --> "XACRO example with PR2"

I tried to adapt the commands on my case. So the two commands look like this:

param name="robot_description" command="$(find xacro)/ $(find franka_ros)/franka_description/robots/hand.urdf.xacro"

node name="spawn_urdf" pkg="gazebo_ros" type="spawn_model" args="-param robot_description -urdf -model hand"

My file hierarchy is following:



with the following in it:





But the terminal gives back following:

WARN: unrecognized 'param' tag in <include> tag

What have I done wrong?

WARN: unrecognized 'node' tag in <include> tag
edit retag flag offensive close merge delete


I'm also facing same problem with panda. If you are using moveit then with moveit setup assistant you can generate the URDF file from your xacro file and that URDF file can be used to spawn panda in gazebo.

mvish7 gravatar imagemvish7 ( 2018-12-24 10:45:45 -0600 )edit

I converted the .urdf.xacro files from the robot with this command: "rosrun xacro xacro --inorder panda_arm_hand.urdf.xacro > pand_arm_hand.urdf" It worked. Now I have no concrete idea how to import this .urdf file correctly in gazebo? Can you tell me please how you done it?

12melvin gravatar image12melvin ( 2019-01-02 06:47:24 -0600 )edit

Hey! I know it's been a year now after the last comment. As I am stuck at the same problem with with URDF files, I wanted to as whether anyone of you got it solved?

JD gravatar imageJD ( 2020-04-02 15:09:50 -0600 )edit