Gazebo | Ignition | Community
Ask Your Question

Problems spawing a simple object

asked 2013-03-31 15:53:52 -0600

Davinci gravatar image

updated 2013-03-31 16:05:42 -0600

As I had much problems with gazebo under fuerte I decieded to try out groovy with gazebo 1.3. But it won´t spawn a simple object.

    Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.

Warning [] Converting a deprecated SDF source[/opt/ros/groovy/stacks/simulator_gazebo/gazebo_worlds/worlds/].
Set SDF value
  Version[1.2] to Version[1.3]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Msg Waiting for master.Msg Waiting for master
Msg Connected to gazebo master @
Msg Publicized address:
[ INFO] [1364762386.117130304]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @
Msg Publicized address:
[ INFO] [1364762387.522566147]: joint trajectory plugin missing <updateRate>, defaults to 0.0 (as fast as possible)
Error [] No <database> tag in the model database manifest.xml found here[]
Error [] Unable to download model manifests

The following command keeps running:

 rosrun gazebo spawn_model -file object.urdf -urdf -z 1 -model my_object
[INFO] [WallTime: 1364763933.932859] [0.000000] waiting for service /gazebo/spawn_urdf_model

I tried to convert the with gzsdf tool but I could not locate the tool..

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-04-01 04:26:01 -0600

AndreiHaidu gravatar image

updated 2013-04-01 10:17:13 -0600


make sure you sourced the setup.bash file:

/<path>/gazebo$ source setup.bash

then run in a terminal:

$ rosrun gazebo gzsdf convert /<path>/your.sdf


/<path>/gazebo$ ./gazebo/bin/gzsdf convert /<path>/your.sdf

(you may need sudo rights for converting the file, or you could just create another one in a different package)


to spawn use:

$ gzfactory spawn -f /<path>/model.sdf -m model_name -x 1 -y 1 -z 2 -R 0 -P 0 -Y 0

Cheers, Andrei

edit flag offensive delete link more


I can find the plugin now but I can't convert the empty world. That does not seem to be the problem. I think spawn_model does not work anymore?

Davinci gravatar imageDavinci ( 2013-04-01 09:34:51 -0600 )edit

and why cant you convert the world file? that should also work, did you try it with sudo?

AndreiHaidu gravatar imageAndreiHaidu ( 2013-04-01 10:18:15 -0600 )edit

spawning works now thanks. Weird that I also had to source the gazebo setup,bash, this was not necessary in fuerte.

Davinci gravatar imageDavinci ( 2013-04-01 11:23:29 -0600 )edit

Question Tools


Asked: 2013-03-31 15:53:52 -0600

Seen: 2,090 times

Last updated: Apr 01 '13