Gazebo | Ignition | Community
Ask Your Question

Symbol lookup error (both instalation methods)

asked 2019-03-04 21:48:06 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

After installation I get the following error when typing gazebo:

pedro@pedro-MS-7972:~$ gazebo
gazebo: symbol lookup error: /usr/lib/x86_64-linux-gnu/ undefined symbol: _ZN8ignition10fuel_tools12ClientConfig12SetUserAgentERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

Any ideas why I get this error? I tried to install it from source and using script in both cases got same error.

edit retag flag offensive close merge delete


When you install from source, do you install Ignition Fuel Tools?

chapulina gravatar imagechapulina ( 2019-03-05 12:39:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-03-28 09:34:46 -0500

Zleepy gravatar image

I think I installed from source first, got an SSL error ([Err] [] Error in REST request), reinstalled from script and got the same error you got.

Found the solution here: Your ignition-math version is out of date. Use "sudo apt upgrade libignition-math2" to solve it.

edit flag offensive delete link more


It worked for me. Thanks!

jhansi99 gravatar imagejhansi99 ( 2020-09-01 02:35:52 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-03-04 21:48:06 -0500

Seen: 3,899 times

Last updated: Mar 04 '19