custom 3d mesh does not show in Gazebo

asked 2019-04-02 07:59:27 -0600

Ince gravatar image

I am a new ROS user. I wrote a SDF file and tried including a *.dae file I have using model://mymodelname/meshes/filename.dae but the mesh is not appearing in Gazebo.

Then I tried creating a new folder under .gazebo/models but I get a message saying permission denied.

I am not sure how to go about since it does not get the information from my package and the model therein.

How can I alleviate the problem I have. Any help would be appreciated. Erhan

edit retag flag offensive close merge delete

Comments

You can try running gazebo in verbose mode. It shows the warnings or error messages not shown in the regular mode. Assuming you are using Ubuntu, try creating the folder inside ~/.gazebo/models using 'sudo' command.

shiveshkhaitan gravatar imageshiveshkhaitan ( 2019-04-04 04:52:43 -0600 )edit

Can you post your code here? That way it is easier to attempt to replicate the problem you have. Your SDF file and your hierarchical directory to your .dae file.

afroRoboticist gravatar imageafroRoboticist ( 2019-04-05 09:19:43 -0600 )edit

I am using https://rds.theconstructsim.com currently.

I have created a share link to the project and it is as follows

http://www.rosject.io/l/8cf2f60/

If I find no solution to this problem I am going to try Ubuntu 16.04 with kinetic ROS. But this is my second preference.

Ince gravatar imageInce ( 2019-04-08 08:09:30 -0600 )edit

Hi, @Ince I sincerely doubt this is an OS problem. I tried seeing your project via the link you posted and it says I need to be authenticated to view it. If you go to the URDF folder of your rosject, you'll see your URDF file which represents your robot. Copy that and your launch files and post them here. That's the only way we can recreate your problem and proffer a solution.

afroRoboticist gravatar imageafroRoboticist ( 2019-04-09 03:17:05 -0600 )edit