Gazebo | Ignition | Community
Ask Your Question
0

Gazebo Ardupilot interface for Husky rover not working properly

asked 2019-05-22 02:42:22 -0500

Withered_Shadow gravatar image

Hey,

So I installed husky rover simulation with the instructions given here link text. I am also using Ardupilot and using the Github repo from SwiftGust link text. However when I run the ardupilot for rover and Gazebo husky simultaneously, and give a point for the rover to move towards, it moves in a very curvy manner instead of moving along a straight line. Im not sure if related but I also get the error

Failed to load plugin libhusky_gazebo_plugins.so

What is the fix for this?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-03-31 08:16:51 -0500

Asif Khan gravatar image

Actually, libhusky_gazebo_plugins.so simply doesn't exist. What you have to do is remove the related plugin line from your SDF, and you will notice no change in the movements of the husky bot. And to fix the way husky is running, you can try changing the mass of the model and friction prams. In my case, changing mass worked.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-22 02:42:22 -0500

Seen: 217 times

Last updated: May 22 '19