"Save as" won't load when clicked [closed]

asked 2019-09-10 13:41:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Using Gazebo 9.11.0; All that appears in the terminal with the --verbose flag is: Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

After waiting a few minutes, this appears: [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/user_camera/pose, deleting message. This warning is printed only once.

Once I press ^C, I can browse for where to save it for only a brief second, and then it disappears along with the rest of Gazebo's gui. I also noticed that when I browse for a custom shape in the model editor, I had the same problem with the same output but now it works for some reason.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Victoria Bentell
close date 2019-09-13 12:41:55.943400


How did you install Gazebo and what platform are you on?

chapulina gravatar imagechapulina ( 2019-09-10 16:21:28 -0500 )edit

I'm using Ubuntu 18.04, and I originally installed Gazebo with Ros (not sure what version of Gazebo at the time), then upgraded Gazebo to 9.11.0. I just upgraded it to 10.1.0 and the same problem occurs.

Victoria Bentell gravatar imageVictoria Bentell ( 2019-09-10 21:38:10 -0500 )edit

Run gazebo as superuser

Tobi92 gravatar imageTobi92 ( 2019-09-12 03:46:20 -0500 )edit

Running with sudo worked! Thank you very much!

Victoria Bentell gravatar imageVictoria Bentell ( 2019-09-13 12:41:32 -0500 )edit