How to achieve stable contact of the robot's wheel with the ground?

asked 2019-10-30 09:40:40 -0500

kumpakri gravatar image

I find my wheeled robot slipping over a surface that he is not supposed to be slipping. When I watch the contacts in the Gazebo client, I can see that the robot is not slipping if the contacts are stable and is slipping the more the more the contacts flicker.

I set all the configuration I thought might have an effect on this but nothing helped. The contacts are still unstable.

In the world description I set physics tags:

 <max_contacs> to 1
 <cfm> to 0.002
 <contact_surface_layer> to 0.01

In the link of the wheels I set

 <minDepth> to 0.002
 <maxVel> to 0.5
 <max_contacts> to 1

I have made a plugin that always assigns the fdir1 to the unit vector opposite of the heading direction.

iters nor friction method makes any difference for contacts. What else can I try?

edit retag flag offensive close merge delete