Changing <contact_surface_layer> value does not make any difference

asked 2019-11-01 05:43:46 -0500

kumpakri gravatar image

According to the ODE documentation the ContactSurfaceLayer defines a depth of the surface layer around all geometry objects to which contacts are allowed to sink before coming to rest. The default value is zero and increasing this to some small value is supposed help prevent jittering contacts. But when I increase the value (I can see the changed value in the Gazebo GUI) nothing changes. The contacts stay jittery. I would expect the geometries of the models to actually sink into eachother, but that does not happen. I tried values of 0.001, 0.01, 0.1 and even 1.0, but nothing changed. I assume the value of 1.0 should cause the models to sink 1 meter into each other, but they stay perfectly on top of each other.

Why does the <contact_surface_layer> not have any effect on the simulation? Is there a way how to enable it? I am really struggling with jittering contacts. Is there other way how to stabilize the contacts?

edit retag flag offensive close merge delete