Gazebo | Ignition | Community
Ask Your Question
0

Simulation doesn't fully fill the Gazebo window

asked 2019-12-04 07:40:53 -0500

Matthias Mayr gravatar image

When launching Gazebo the simulation view doesn't fully fill the Gazebo window. I get borders that are either black or filled old previously rendered material (e.g. background image of that screen).

Gazebo doesn't give me any useful feedback on this when being started in --verbose mode.

Here's a screenshot: image description

I can use the border to scroll and move the content of the "simulation view", but it never shows anything there. The size of the border seems to be some ratio of the whole window, so if I resize it I get the same proportions of used and unused windows space.

This is with:

  • (K)Ubuntu 18.04
  • X-Server 1.20.4
  • Nvidia driver 430.50
  • Kernel 5.0.0-36
  • Gazebo 9.0.0+dfsg5-3ubuntu1+ppa2

Also the buttons of the visualization part are very low resolution and so is the Gazebo startup display. All the rest of the window is fine though.

Any ideas for solution or debugging steps?

edit retag flag offensive close merge delete

Comments

Have you solved this problem?

bionade24 gravatar imagebionade24 ( 2020-03-08 10:42:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-03-14 11:30:55 -0500

bionade24 gravatar image

Gazebo can't handle scaling which is automatically done by the proprietairy nvidia driver when having > 1920.1080 pixel. You have to disable display scaling. Maybe this can help you to let gazebo work scaled without errors, too: https://github.com/kaueraal/run_scaled
Issue is tracked here: https://bitbucket.org/osrf/gazebo/iss...

edit flag offensive delete link more

Comments

Thanks for the reply. For some reason I did not get a notification about it. The issue has been moved here: https://github.com/osrf/gazebo/issues...

Matthias Mayr gravatar imageMatthias Mayr ( 2020-07-19 11:20:10 -0500 )edit

I tried run_scaled and it indeed removes the borders, but it also renders the fonts so big that e.g. the time in the status bar can not be read anymore.

Matthias Mayr gravatar imageMatthias Mayr ( 2020-07-19 11:34:53 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-12-04 07:40:53 -0500

Seen: 142 times

Last updated: Mar 14 '20