Gazebo | Ignition | Community
Ask Your Question
0

Cannot start Gazebo (no Gui)

asked 2020-01-07 04:51:16 -0500

paolob gravatar image

updated 2020-01-23 11:52:49 -0500

Jose Luis Rivero gravatar image

I am new to Gazebo and Ubuntu. I have just installed Ubuntu 18.04 and Gazebo 10.0. When I start Gazebo entering command $ gazebo --verbose no Gui show up...the message I get are:

[Msg] Waiting for master. Gazebo multi-robot simulator, version 9.11.0 Copyright (C) 2012 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.139 [Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.139

$ gzserver --verbose

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 192.168.1.139 Segmentation fault (core dumped)

$ gzclient --verbose

[Msg] Waiting for master. [Err] [ConnectionManager.cc:119] Failed to connect to master in 30 seconds. [Err] [gazebo_shared.cc:83] Unable to initialize transport. [Err] [gazebo_client.cc:62] Unable to setup Gazebo

Thanks for your suggestions!

Paolo

edit retag flag offensive close merge delete

Comments

Could you please try running gzserver --verbose in one shell and gzclient --verbose in other shell and see if the logs display something different?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2020-01-23 09:45:23 -0500 )edit

Thanks Jose Luis this is what i get: gzserver messages:

[Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.139 Segmentation fault (core dumped)

gzclient messages: [Msg] Waiting for master. [Err] [ConnectionManager.cc:119] Failed to connect to master in 30 seconds. [Err] [gazebo_shared.cc:83] Unable to initialize transport. [Err] [gazebo_client.cc:62] Unable to setup Gazebo

paolob gravatar imagepaolob ( 2020-01-23 11:40:05 -0500 )edit

Segfaulting booting Gazebo. What kind of graphic card do you have? Which is the output of lspci | grep VGA ?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2020-01-23 11:54:26 -0500 )edit

paolo@paolo-Inspiron-9300:~$ lspci|grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation NV41M [GeForce Go 6800] (rev a2)

paolob gravatar imagepaolob ( 2020-01-23 12:02:01 -0500 )edit

If the nvidia support is enabled (install mesa-utils and run glxinfo | grep direct), next step would be to look into the logs ~/.gazebo/logs/ to see if there is an error message in there.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2020-01-27 11:39:30 -0500 )edit

This is what Iget: paolo@paolo-Inspiron-9300:~$ glxinfo |grep direct direct rendering: Yes paolo@paolo-Inspiron-9300:~$ ls .gazebo client-11345 gui.ini ogre.log server-11345 paolo@paolo-Inspiron-9300:~$ No log directory under .gazebo! I am discouraged....

paolob gravatar imagepaolob ( 2020-01-29 07:40:23 -0500 )edit

You will find log files inside .gazebo/client-11345 and .gazebo/server-11345. There could be some hint there about what is failing. Also give a look into ogre.log. Check for errors.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2020-01-30 09:42:11 -0500 )edit

only ogre.log contain some info.

paolob gravatar imagepaolob ( 2020-01-31 07:53:10 -0500 )edit

Sorry I dont know how to attach the file........

paolob gravatar imagepaolob ( 2020-01-31 08:03:23 -0500 )edit

edit the answer and include the relevant error lines please

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2020-02-03 11:08:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-02-13 07:58:21 -0500

paolob gravatar image

SOLVED!!! After several trial, i succeed to install a nvidia driver.... Now the screen has a lower resolution, but gazebo start and show the Gui screen.... I hope that i can continue without additional problems....... Thanks!!!

edit flag offensive delete link more

Comments

Unfortunately this did not solve my problems..... I noticed a lower resolution but what is worse is that display do not use GPU acceleration, this is because my graphic cards is no more supported on Ubuntu 19.04. So or I use the Ubuntu driver "nouveau" or I have to get back to Ubuntu 16.04 or older. There is any way the nouveau driver can be used? I need to use gazebo with Ardupilot SITL and I am afraid it could not be compatible with previous Ubuntu versions.

paolob gravatar imagepaolob ( 2020-03-13 12:07:48 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-07 04:51:16 -0500

Seen: 389 times

Last updated: Feb 13