How to enable bounce with DART engine?

asked 2020-01-29 00:56:43 -0600

hued gravatar image

updated 2020-02-11 00:17:50 -0600

Hi all,

I want to simulate bounce with the DART engine. I set restitution_coefficient and threshold under the bounce tag, however, it does not work.

This answer says that max_vel value under the ode tag must be also set. However, max_vel is valid only when ODE is set as the physics engine.

In addition, when max_vel is set, restitution_coefficient and threshold are ignored, then kp and kd under the ode tag are referred (This answer's last comment mentions it).

Is there any way to set a restitution coefficient with DART engine?

Here is my world.sdf and I run it Gazebo 9 on Ubuntu18.04.

Thank you.

<?xml version="1.0" ?>
<sdf version="1.6">
  <world name="world">
    <gravity>0 0 -9.80665</gravity>
    <physics default="true" type="dart">
    <!-- <physics type="ode">
    </physics> -->

    <!-- A global light source -->

    <!-- Ground -->

    <!-- Ball -->
    <model name="Ball">
      <pose>0 0 2 0 0 0</pose>
      <link name="Ball">
        <pose>0 0 0 0 0 0</pose>
          <pose>0 0 0 0 0 0</pose>
        <visual name="vis_Ball">
        <collision name="coll_Ball">
          <pose>0 0 0</pose>
            <!-- <contact>
            </contact> -->

edit retag flag offensive close merge delete


hi, I find the same bounce issue in Bullet physics engine. did you solve the problem? Thank you

tom8o gravatar imagetom8o ( 2022-09-09 14:10:20 -0600 )edit