Gazebo | Ignition | Community
Ask Your Question
0

Unable to run Gazebo 11 and old project after installation from source

asked 2020-03-05 18:04:13 -0500

Suyash gravatar image

Hi,

I reinstalled Gazebo 11 from source after uninstalling it (which I installed from debians). The earlier version was Gazebo 9. Actually, I need to try DART for running an old project. I followed the 'installation from source' instructions as provided on: http://gazebosim.org/tutorials?tut=in.... Also, I installed the gazebo_ROS_pkgs as described on: http://gazebosim.org/tutorials?tut=ro.... However, when I am trying to run the same old project after re-installation, I am getting the following errors. Also, when I run just Gazebo, I get the errors as described below in the second box. Please suggest the needful. Please let me know if any more details are required. Thank you.

Error when I run my old project:

Service [/physics/info/plugin] is not valid.
[Err] [World.cc:275] Error advertising service [/physics/info/plugin]
[Wrn] [ODEPhysics.cc:214] Gravity vector is (0, 0, 0). Objects will float.
Service [/introspection/livnqn/filter_new] is not valid.
[Err] [IntrospectionManager.cc:51] Error advertising service [/introspection/livnqn/filter_new]
Service [/introspection/livnqn/filter_update] is not valid.
[Err] [IntrospectionManager.cc:59] Error advertising service [/introspection/livnqn/filter_update]
Service [/introspection/livnqn/filter_remove] is not valid.
[Err] [IntrospectionManager.cc:67] Error advertising service [/introspection/livnqn/filter_remove]
Service [/introspection/livnqn/items] is not valid.
[Err] [IntrospectionManager.cc:75] Error advertising service [/introspection/livnqn/items]
Topic [/introspection/livnqn/items_update] is not valid.
[Err] [IntrospectionManager.cc:85] Error advertising topic [/introspection/livnqn/items_update]
Topic [/mahu03_r013/joint_cmd] is not valid.
[Err] [JointController.cc:51] Error subscribing to topic [/mahu03_r013/joint_cmd]
Service [/mahu03_r013/joint_cmd_req] is not valid.
[Err] [JointController.cc:58] Error advertising service [/mahu03_r013/joint_cmd_req]
[libprotobuf ERROR google/protobuf/descriptor_database.cc:57] File already exists in database: ignition/msgs/time.proto
[libprotobuf FATAL google/protobuf/descriptor.cc:1164] CHECK failed: generated_database_->Add(encoded_file_descriptor, size): 
terminate called after throwing an instance of 'google::protobuf::FatalException'
  what():  CHECK failed: generated_database_->Add(encoded_file_descriptor, size):

Moreover, when I try to run just gazebo, I get the following errors:

Service [/introspection/vwsgsb/filter_new] is not valid.
Service [/introspection/vwsgsb/filter_update] is not valid.
Service [/introspection/vwsgsb/filter_remove] is not valid.
Service [/introspection/vwsgsb/items] is not valid.
Topic [/introspection/vwsgsb/items_update] is not valid.
Service [/marker/list] is not valid.
Service [/marker] is not valid.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-03-05 18:35:26 -0500

chapulina gravatar image

Your errors indicate that you may be mixing 2 versions of protobuf, and therefore 2 versions of Gazebo. Make sure you installed gazebo_ros_pkgs from source, so you use a version that is compiled against Gazebo 11, not Gazebo 9.

edit flag offensive delete link more

Comments

Thank you for your answer. I still have some issues: I uninstalled ROS and Gazebo followed by reinstalling ROS. I then reinstalled gazebo9 from source followed by gazebo_ros_pkgs from source, as described in the tutorial. However, when I try to run gazebo using roscore & rosrun gazebo_ros gazebo, gazebo 11 opens up with errors. I believe when I try to install gazebo9, it installs gazebo 11 but compilation happens against gazebo9, as I encountered unmet dependencies against gazebo9.

Suyash gravatar imageSuyash ( 2020-03-09 21:52:18 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-05 18:04:13 -0500

Seen: 560 times

Last updated: Mar 05 '20