Gazebo | Ignition | Community
Ask Your Question

[ignition] Blank window when trying to run shapes.sdf

asked 2020-03-28 01:35:30 -0500

Mohamed_Ahmed gravatar image

updated 2020-03-30 11:35:21 -0500

chapulina gravatar image

when I try to run this command ign gazebo shapes.sdf -v 4
I got a blank window. I tried to run a world which uses Ogre1 ign gazebo -v 3 lights.sdf
but the same blank window. I also tried to use the Acropolis but the same issue
this is the output from the terminal when running lights.sdf

[Msg] Ignition Gazebo GUI    v2.16.0
[Msg] Ignition Gazebo Server v2.16.0
[Msg] Loading SDF world file[/usr/share/ignition/ignition-gazebo2/worlds/lights.sdf].
[Msg] Create service on [/world/lights/create]
[Msg] Remove service on [/world/lights/remove]
[Msg] Pose service on [/world/lights/set_pose]
[Msg] Loaded level [3]
[Msg] Serving world controls on [/world/lights/control] and [/world/lights/playback/control]
[Msg] Serving GUI information on [/world/lights/gui/info]
[Msg] World [lights] initialized with [1ms] physics profile.
[Msg] Found no publishers on /stats, adding root stats topic
[Msg] Found no publishers on /clock, adding root clock topic
[Msg] Serving scene information on [/world/lights/scene/info]
[Msg] Serving graph information on [/world/lights/scene/graph]
[Msg] Serving full state on [/world/lights/state]
[Msg] Publishing scene information on [/world/lights/scene/info]
[Msg] Publishing entity deletions on [/world/lights/scene/deletion]
[Msg] Publishing state changes on [/world/lights/state]
[Msg] Publishing pose messages on [/world/lights/pose/info]
[Msg] Publishing dynamic pose messages on [/world/lights/dynamic_pose/info]

when running the shapes.sdf I got similar output adding the same output except this line is added

[GUI] [Dbg] [] GUI requesting list of world names. The server may be busy downloading resources.     Please be patient.

OS: Ubuntu 18.04
Ignition: Blueprint
OpenGL version string: 4.6.0 NVIDIA 390.116

edit retag flag offensive close merge delete


Are any errors / warnings printed which could indicate what's happening?

chapulina gravatar imagechapulina ( 2020-03-28 11:27:43 -0500 )edit

I edited my question

Mohamed_Ahmed gravatar imageMohamed_Ahmed ( 2020-03-28 11:58:17 -0500 )edit

While the window is black, could you check ign service -l to see if there's a /gazebo/worlds service? You may need to run the command more than once.

chapulina gravatar imagechapulina ( 2020-03-30 11:37:36 -0500 )edit

I run the command multiple times but there is no output

Mohamed_Ahmed gravatar imageMohamed_Ahmed ( 2020-03-31 01:10:47 -0500 )edit

Can you run ign service --versions and see if you have more than one installed? You may have a weird mix of versions and the client is not being able to speak to the server.

chapulina gravatar imagechapulina ( 2020-03-31 11:41:00 -0500 )edit

here is the output 7.4.0

Mohamed_Ahmed gravatar imageMohamed_Ahmed ( 2020-04-01 02:36:37 -0500 )edit

Thanks, I see you have Gazebo 9, Ignition Acropolis and Ignition Blueprint installed. It looks like you're having this unresolved issue:

chapulina gravatar imagechapulina ( 2020-04-01 11:55:07 -0500 )edit

@chapulina, is there a new link to that unresolved issue? The link appears broken.

SamG gravatar imageSamG ( 2022-07-05 20:39:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2020-12-18 13:25:58 -0500

ahcorde gravatar image

Did you try to remove ~/.ignition/gazebo/gui.config ?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2020-03-28 01:35:30 -0500

Seen: 954 times

Last updated: Dec 18 '20