Gazebo | Ignition | Community
Ask Your Question
1

Plugins in Gazebo 9 - ROS Melodic

asked 2020-04-08 03:53:01 -0500

Anton gravatar image

updated 2020-04-10 13:18:21 -0500

Hello,

I am having trouble using plugins in Gazebo 9.0.0, that came pre-installed with ROS. The specific plugin I'm trying to make work is the Actor Collions plugin (Found here)

I have tried downloading the plugin files, but it doesn't seem to have any effect on the collision of the actor at all.

Is this due to Gazebo not being a source installation, or something else entirely?

Thanks in advance!

EDIT:
I followed the install tutorial here, to install Gazebo 9.13.
I then downloaded the example files from the OSRF bitckbucket using the 9.13 tag. I put the actor_collisions example folder in a workspace by itself and tried running "gazebo actor_collisions.world" from the terminal.
I have tried both with and without using catkin_make to build my workspace first. The result is the actor walking around among the objects, but there's still no collision.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-04-21 16:04:37 -0500

relffok gravatar image

updated 2020-04-21 16:05:00 -0500

Hi, have you tried running it with the --verbose flag?

When I follow the steps you linked and run: gazebo ../actor_collisions.world --verbose I get the error that the plugin could not be found:

Failed to load plugin libActorCollisionsPlugin.so: libActorCollisionsPlugin.so: cannot open shared object file: No such file or directory

If this is your case, you might need to set the environment variable, to tell Gazebo where to look for your plugin, something like this: export GAZEBO_PLUGIN_PATH=$GAZEBO_PLUGIN_PATH:{path_to_your_ws}/actor_collisions/build and run the command again.

edit flag offensive delete link more

Comments

Thank you! This fixed my problem.

Anton gravatar imageAnton ( 2020-04-28 02:34:15 -0500 )edit
1

answered 2020-04-08 11:26:54 -0500

chapulina gravatar image

As you can see on the changelog, for Gazebo major version 9, that plugin is only available from Gazebo 9.1.0. Follow the install instructions here to install the latest minor release.

edit flag offensive delete link more

Comments

Thanks, that makes sense! As I'm using ROS Melodic, I would prefer to not use anything newer than Gazebo 9.x. What is the easiest way to install 9.13? When I use the command "sudo apt-get install gazebo9=9.13.0", i get an error that says this version was not found

EDIT: "sudo apt-get install gazebo9=9.13.0-1*" worked. Will test if this solves my initial problem

Anton gravatar imageAnton ( 2020-04-09 03:41:16 -0500 )edit

Upgrading to 9.13 did not fix the issue. I downloaded the example files from the 9.13 commit on Bitbucket (https://bitbucket.org/osrf/gazebo/com...) so I think the files are correct...

Anton gravatar imageAnton ( 2020-04-09 04:28:53 -0500 )edit

Oh no :/ Could you update the question with steps to reproduce the issue and the error output you're seeing?

chapulina gravatar imagechapulina ( 2020-04-09 16:16:17 -0500 )edit

Yeah :/ I have updated the question, looking forward to your response :)

Anton gravatar imageAnton ( 2020-04-10 13:19:04 -0500 )edit

Hello chapulina, do you by chance have an update?

Anton gravatar imageAnton ( 2020-04-21 04:31:52 -0500 )edit

Did you follow these instructions? Also, does running with --verboseprint any errors? https://github.com/osrf/gazebo/blob/g...

chapulina gravatar imagechapulina ( 2020-04-21 21:40:58 -0500 )edit

Thank you, your link along with relffok's answer solved my issue :)

Anton gravatar imageAnton ( 2020-04-28 02:33:17 -0500 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2020-04-08 03:52:30 -0500

Seen: 307 times

Last updated: Apr 21