Gazebo 9 can't run on VMWare without downgrading to OpenGL 2.1 or turning off 3D Acceleration

asked 2020-04-16 11:11:55 -0500

When launching Gazebo v9 (latest of v9) on VMWare with 3D Acceleration I get the following error message:

VMware: vmw_ioctl_command error Invalid argument.

I have looked around for a solution here and on VMWare forum and all suggested solutions hint at turning off 3D acceleration or downgrading to OpenGL 2.1 via exporting SVGA_VGPU10=0 before running gazebo:

http://answers.gazebosim.org/question...

https://answers.gazebosim.org/questio...

There also seem to be an open ticket on this:
https://bitbucket.org/osrf/gazebo/iss...
Which unfortunately also hints at downgrading to OpenGL 2.1 as a workaround.

While this maybe a solution for many, it doesn't help for my use case. I need to use Gazebo under VMWare with 3D acceleration turned on and without having to downgrade to OpenGL 2.1. The reason is I rely on some of the feature set provided by OpenGL 3.0.

I would like to know if this a VMWare problem (other 3d software seem to run fine) or a Gazebo issue? Is there a real solution? Or is it being addressed?

I am running: VMWare Fusion 11.5 / Ubuntu 18 VM / Gazebo 9. VM configuration: 4 cores / 8 GB system memory / 2GB gpu memory

edit retag flag offensive close merge delete