Setting <split_impulse_penetration_threshold> tag of bullet Engine in .world file does not work

asked 2020-05-04 12:42:27 -0500

mazeyu gravatar image

Here's the code of the .world file. Whatever I change -0.05 to be, both + and -, the gap between objects in gazebo is always the same and seems -0.01, the default value. But when I add <erf> etc. in <constraints> tag, things do happen. So it confirms gazebo is reading this file. But I cannot figure out why the value of split_impulse_penetration_threshold is ignored.

<sdf version="1.6"> <world name="default">

<!-- A global light source -->
<include>
  <uri>model://sun</uri>
</include>

<!-- A ground plane -->
<include>
  <uri>model://ground_plane</uri>
</include>
<physics type="bullet">

      <bullet>
        <constraints>


            <contact_surface_layer> 0 </contact_surface_layer>
            <split_impulse> 1 </split_impulse>
            <split_impulse_penetration_threshold> -0.05 </split_impulse_penetration_threshold>
        </constraints>
      </bullet>
</physics>

</world> </sdf>

enter code here

edit retag flag offensive close merge delete