Gazebo | Ignition | Community
Ask Your Question
0

Gazebo error - [REST.cc:205] Error in REST request

asked 2020-05-05 00:53:16 -0500

Ismaiel gravatar image

Hello everyone,

I have the following problem while starting Gazebo 9 from terminal [Err] [REST.cc:205] Error in REST request image description

Does anyone have an idea how to solve it ?

edit retag flag offensive close merge delete

Comments

this has been previously discussed on this forum. the problem can be resolved by editing gazebo's config file.

altineller gravatar imagealtineller ( 2020-05-06 13:56:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-05-06 07:34:25 -0500

rickstaa gravatar image

Hey, @Ismaiel welcome to the forum. As can be seen in this issue this error is probably caused because the ~/.ignition/fuel/config.yaml file still points to the old ignition fuel domain. This error can be solved by replacing url: https://api.ignitionfuel.org by url: https://api.ignitionrobotics.org inside the ~/.ignition/fuel/config.yaml file.

edit flag offensive delete link more

Comments

Yap, that resolved mine. Very straight answer.

Ricardo Pinto gravatar imageRicardo Pinto ( 2020-05-07 12:57:04 -0500 )edit

This worked for me, thanks!

desmond13 gravatar imagedesmond13 ( 2020-11-25 10:07:46 -0500 )edit

I am not able to find ~/.ignition/fuel/config.yaml file , can anyone help me where to find it ??

aayush gravatar imageaayush ( 2021-05-05 03:02:12 -0500 )edit

@aayush when you open a terminal and write "ls -a" you will see ".ignition" file

mustafa gravatar imagemustafa ( 2021-08-18 02:01:59 -0500 )edit
0

answered 2020-05-05 08:49:54 -0500

ahcorde gravatar image

This error is explained here https://answers.gazebosim.org//questi...

You can also find this video useful https://www.youtube.com/watch?v=ftDz_...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-05 00:53:16 -0500

Seen: 12,099 times

Last updated: May 06 '20