Roslaunch Gazebo in WSL

asked 2020-05-05 01:20:03 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I am trying to roslaunch gazebo_ros empty_world.launch on my terminal and it gives the following error:

[gazebo-1] process has died [pid 8381, exit code 2, cmd /opt/ros/melodic/lib/gazebo_ros/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/loguna/.ros/log/0c8c17a4-8e7c-11ea-9157-a434d99a9cc7/gazebo-1.log]. log file: /home/loguna/.ros/log/0c8c17a4-8e7c-11ea-9157-a434d99a9cc7/gazebo-1.log [gazebo_gui-2] process has died [pid 8383, exit code 2, cmd /opt/ros/melodic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/loguna/.ros/log/0c8c17a4-8e7c-11ea-9157-a434d99a9cc7/gazebo_gui-2.log]. log file: /home/loguna/.ros/log/0c8c17a4-8e7c-11ea-9157-a434d99a9cc7/gazebo_gui-2.log

I have tried running gazebo independently and it works fine. The issue comes when I tried to roslaunch it. May I know how to solve this problem?

edit retag flag offensive close merge delete