Sensor appearing at wrong place

asked 2020-05-26 09:29:14 -0600

mamurtaza gravatar image

updated 2020-05-26 13:48:13 -0600

I am trying to follow the tutorial at http://gazebosim.org/tutorials?tut=bu... and in its third part http://gazebosim.org/tutorials/?tut=a...

I added the laser. However the laser appeared at the bottom of the robot instead of the top. This makes robot stand on the laser. Visually laser is in the air with some space and robot is on the top of it. Clicking robot shows that there is 4 links (chasis, left wheel, right wheel and link). Its calling hokuyo as link and the pose is (-0.000002, 0, 0.000005,0,0,0). hokuyo_joint is at position (0,0,0).

I am not sure what is messing it up or if tutorial is wrong. Any help will be appreciated.

I am using gazebo11.

edit retag flag offensive close merge delete

Comments

I'm getting the same issue, can't seem to get the pose to be in the correct position

Arc170 gravatar imageArc170 ( 2020-08-03 10:53:11 -0600 )edit

I was able to solve it by doing the following: <link name="hokuyo::link"> <pose>0.1 0 0.25 0 0 0</pose>
</link> <include> <uri>model://hokuyo</uri> <pose>0.1 0 0.25 0 0 0</pose> </include> <joint name="hokuyo_joint" type="fixed"> <child>hokuyo::link</child>

mamurtaza gravatar imagemamurtaza ( 2020-08-10 01:38:09 -0600 )edit