Gazebo | Ignition | Community
Ask Your Question
0

how to increase real time factor while doing simulation

asked 2020-05-28 21:00:37 -0600

Carrot12138 gravatar image

When I load an empty world in gazebo,the real time factor is close to 1,but if I load a pr2 model in the gazebo environment,the value of it decrease to 0.2.How to increase the value of real time factor when doing simulation with pr2? I tried modifying the physics link in the wrold file,but it didn't help...

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-05-29 03:27:15 -0600

nlamprian gravatar image

On the left panel, go to the World Tab and click on Physics. Then change the real time update rate to 0. This will make gazebo run as fast as possible.

image description

edit flag offensive delete link more

Comments

Thank you for your answer,this solution works well in some situation.My problem seems to be related to the hardware configuration of my computer,so that after I modified the physics tag,the robot still move slow in the gazebo.

Carrot12138 gravatar imageCarrot12138 ( 2020-06-07 04:13:04 -0600 )edit

FYI as fast as possible does not mean faster than real time. If your model is too complicated, or your computer doesn't have enough resources, gazebo might still run slower than real time.

nlamprian gravatar imagenlamprian ( 2020-06-08 08:51:03 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-28 21:00:37 -0600

Seen: 390 times

Last updated: May 29