Gazebo | Ignition | Community
Ask Your Question
0

Unable to change the default pose of human actors when using talk_a.dae or talk_b.dae

asked 2020-06-18 22:41:09 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Below is a section of my code: <actor name="actor3"> <pose>-2 -4 0.2 0 0 1.57</pose> <skin> <filename>talk_a.dae</filename> <scale>1.0</scale> </skin> <animation name="talk_a"> <filename>talk_a.dae</filename> </animation> </actor>

I am using Gazebo 9. I would like to load this actor at a specified pose but the pose does not seem to be applied even if I specify in the code. Any help would be appreciated. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-06-19 12:55:25 -0600

chapulina gravatar image

updated 2020-06-19 12:55:47 -0600

This is not ideal, but one trick is to also add a <script><trajectory> with 2 waypoints that have the same pose. Here's an example:

  <actor name="talkingA">
    <pose>5 5 5.76 0 0 0</pose>
    <skin>
      <filename>model://actor/meshes/SKIN_man_blue_shirt.dae</filename>
    </skin>
    <animation name="animation">
      <filename>model://actor/meshes/ANIMATION_talking_a.dae</filename>

    </animation>
      <script>
        <trajectory id="0" type="animation">

            <waypoint>
              <time>100</time>
              <pose>5 5 5.16 0 0 0</pose>
            </waypoint>

            <waypoint>
              <time>100</time>
              <pose>5 5 5.16 0 0 0</pose>
            </waypoint>

        </trajectory>
      </script>
  </actor>
edit flag offensive delete link more

Comments

Thanks a lot! That works for me for now.

PKGosal gravatar imagePKGosal ( 2020-06-20 08:19:46 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-18 22:41:09 -0600

Seen: 86 times

Last updated: Jun 19