Gazebo | Ignition | Community
Ask Your Question
0

Unable to launch gazebo9 from ros-melodic on ubuntu 18.04 [closed]

asked 2020-07-13 09:19:09 -0500

Hi, sorry for bothering but I couldn't find a solution after I googling.

In case of dependency error, I reinstalled the ros melodic and gazebo 9 by

sudo apt remove ros-* sudo apt remove gazebo* sudo apt-get remove libgazebo* sudo apt-get autoremove sudo apt update sudo apt install ros-melodic-desktop-full

Then I

roslaunch gazebo_ros empty_world.launch

it failed to launch and output goes here

... logging to /home/zzhuang/.ros/log/4d7ea3cc-c2dd-11ea-adf9-107b444c6ede/roslaunch-zzhuang-computer-6608.log  
Checking log directory for disk usage. This may take a while.  
Press Ctrl-C to interrupt  
Done checking log file disk usage. Usage is <1GB.  

started roslaunch server http://192.168.0.35:39221/  

SUMMARY  
========

PARAMETERS
 * /gazebo/enable_ros_network: True
 * /rosdistro: melodic
 * /rosversion: 1.14.6

 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)

auto-starting new master
process[master]: started with pid [6618]
ROS_MASTER_URI=http://192.168.0.35:11311

setting /run_id to 4d7ea3cc-c2dd-11ea-adf9-107b444c6ede
process[rosout-1]: started with pid [6629]
started core service [/rosout]
process[gazebo-2]: started with pid [6635]
process[gazebo_gui-3]: started with pid [6641]
[ INFO] [1594406634.180853095]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1594406634.181647545]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[ INFO] [1594406634.216561834]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1594406634.217443493]: waitForService: Service [/gazebo_gui/set_physics_properties] has not been advertised, waiting...
[ INFO] [1594406634.345115625]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1594406634.358672854, 0.008000000]: Physics dynamic reconfigure ready.
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::lock_error> >'
  what():  boost: mutex lock failed in pthread_mutex_lock: Invalid argument
Aborted (core dumped)
[gazebo_gui-3] process has died [pid 6641, exit code 134, cmd /opt/ros/melodic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/zzhuang/.ros/log/4d7ea3cc-c2dd-11ea-adf9-107b444c6ede/gazebo_gui-3.log].
log file: /home/zzhuang/.ros/log/4d7ea3cc-c2dd-11ea-adf9-107b444c6ede/gazebo_gui-3*.log

it stuck here and I have to ctrl+c to stop it.

Any idea to solve it? Much appreciate your help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zhuang42
close date 2020-07-14 08:52:48.778731

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-14 08:52:37 -0500

I fixed that. I messed up my ENV variable.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-07-13 09:19:09 -0500

Seen: 51 times

Last updated: Jul 14