Gazebo | Ignition | Community
Ask Your Question

roslaunch error-Amazon EC2- X Error of failed request: BadMatch (invalid parameter attributes)

asked 2020-08-14 14:47:52 -0500

Malar gravatar image

updated 2020-08-14 18:52:26 -0500


I have an Oracle VirtualBox VM with Ubuntu 16.04 and ROS Kinetic installed, in which I run Gazebo using the following command for a simulation project:

roslaunch turtlebot_gazebo turtlebot_world.launch world_file:=<world file name>

I created an image (in .ova format) of this VM using the export appliance option in VirtualBox and imported it as an AMI in Amazon EC2. I launched a new EC2 instance (t3a.2xlarge) using this AMI and setup Ubuntu desktop for this instance following this tutorial.

After logging in to the EC2 instance using TightVNC, I used the single machine configuration in this tutorial to set environment variables to initialize roscore.

After this when I execute the above Gazebo command I get the following error:

... logging to /home/ubuntu/.ros/log/deb4dc68-daab-11ea-8688-0ae27ab79f70/roslaunch-ip-----------------------------.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see is deprecated; please use xacro instead
started roslaunch server http://ip-172-31-33-240:42337/


 * /bumper2pointcloud/pointcloud_radius: 0.24
 * /cmd_vel_mux/yaml_cfg_file: /opt/ros/kinetic/...
 * /depthimage_to_laserscan/output_frame_id: /camera_depth_frame
 * /depthimage_to_laserscan/range_min: 0.45
 * /depthimage_to_laserscan/scan_height: 10
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 30.0
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /use_sim_time: True

    bumper2pointcloud (nodelet/nodelet)
    cmd_vel_mux (nodelet/nodelet)
    depthimage_to_laserscan (nodelet/nodelet)
    gazebo (gazebo_ros/gzserver)
    laserscan_nodelet_manager (nodelet/nodelet)
    mobile_base_nodelet_manager (nodelet/nodelet)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    spawn_turtlebot_model (gazebo_ros/spawn_model)

auto-starting new master
process[master]: started with pid [3318]

setting /run_id to deb4dc68-daab-11ea-8688-0ae27ab79f70
process[rosout-1]: started with pid [3331]
started core service [/rosout]
process[gazebo-2]: started with pid [3334]
process[spawn_turtlebot_model-3]: started with pid [3339]
process[mobile_base_nodelet_manager-4]: started with pid [3340]
process[cmd_vel_mux-5]: started with pid [3341]
process[bumper2pointcloud-6]: started with pid [3342]
process[robot_state_publisher-7]: started with pid [3343]
process[laserscan_nodelet_manager-8]: started with pid [3344]
process[depthimage_to_laserscan-9]: started with pid [3345]
[ INFO] [1597024232.401174758]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1597024232.401845265]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  148 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  21
  Current serial number in output stream:  21
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::lock_error> >'
terminate called recursively
Aborted (core dumped)
[gazebo-2] process has died [pid 3334, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /opt/ros/kinetic/share/turtlebot_gazebo/worlds/ __name:=gazebo __log:=/home/ubuntu/.ros/log/deb4dc68-daab-11ea-8688-0ae27ab79f70/gazebo-2.log].
log file: /home/ubuntu/.ros/log/deb4dc68-daab-11ea-8688-0ae27ab79f70/gazebo-2*.log

How would I fix this error and get Gazebo to work like it does in my VirtualBox VM?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-08-16 08:55:30 -0500

Malar gravatar image

updated 2020-08-16 08:55:55 -0500

I figured out the issue. and running the below command fixed it for me.

export DISPLAY=:10

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2020-08-14 14:47:52 -0500

Seen: 657 times

Last updated: Aug 16 '20