Problem with ros_control and gazebo

asked 2020-08-17 04:52:40 -0500

msaws gravatar image

I'm new to ros, I exported urdf from solidworks. when I add transmission to urdf and launch it gazebo is not opening it's giving me error as

[INFO] [1597656176.792430594, 0.245000000]: Loading gazebo_ros_control plugin
[ INFO] [1597656176.793072386, 0.245000000]: Starting gazebo_ros_control plugin in namespace: /
[ INFO] [1597656176.794135347, 0.245000000]: gazebo_ros_control plugin is waiting for model URDF in parameter [robot_description] on the ROS param server.
Segmentation fault (core dumped)
[gazebo-1] process has died [pid 16223, exit code 139, cmd /home/xxxxx/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/xxxx/.ros/log/5c2a3c2a-e069-11ea-a169-28d2447fbe91/gazebo-1.log].
log file: /home/xxxxx/.ros/log/5c2a3c2a-e069-11ea-a169-28d2447fbe91/gazebo-1*.log

but if I launch removing transmission tags it's launch perfectly.

I also tried with rrbot it gives me same error

edit: I've noticed it's because of this

  <gazebo>
        <plugin name="gazebo_ros_control" filename="libgazebo_ros_control.so">
            <robotNamespace>/</robotNamespace>
        </plugin>
    </gazebo>
edit retag flag offensive close merge delete