Gazebo | Ignition | Community
Ask Your Question
0

Gazebo 10.1 on Fedora via MobaXterm or PuTTY/Xming starts with black scene

asked 2020-08-20 15:27:30 -0600

RobbieTheK gravatar image

Starting Gazebo via MobaXterm, which has a built in X11 forwarding, as well as PuTTY with Xming starts with a black scene. The menu options to work. The --verbose flag doesn't reveal any errors nor warnings.

What it should look like: C:\fakepath\unnamed.png

What it does look like: C:\fakepath\blackscreen.JPG

Also testing via X2Go, we have to change the LD_LIBRARY_PATH=/usr/lib64/libgl-xlib:${LD_LIBRARY_PATH} following this suggestion and same issue but we do get these warnings:

[Wrn] [GuiIface.cc:122] X server does not support XInput 2
[Wrn] [GuiIface.cc:122] QXcbConnection: XCB error: 1 (BadRequest), sequence: 168, resource id: 78, major code: 130 (Unknown), minor code: 47
[Wrn] [Publisher.cc:142] Queue limit reached for topic /gazebo/default/physics/contacts, deleting message. This warning is printed only once.
AL lib: (WW) alcCloseDevice: Releasing context 0x55b4ea4214b0
AL lib: (WW) alcSetError: Error generated on device (nil), code 0xa002

Any fix for this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-08-24 10:23:10 -0600

RobbieTheK gravatar image

A quick fix is to use the COPR repo and upgrade to 11.1

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-08-20 15:27:30 -0600

Seen: 84 times

Last updated: Aug 24 '20