Fail to install Gazebo in Mac Pro after interruption.

asked 2020-08-20 16:37:03 -0500

*I tried to install gazebo in my Mac pro, then I accidentally disturbed it. Then I run the command (curl -ssL http://get.gazebosim.org | sh) again, showed the following. I would like to know 1. How to reverse the whole process, to cancel all the scripts/ files have been installed, and just do it again from the beginning? 2. How to fix the following problem if I cannot redo everything?*

Last 15 lines from /Users/weiwang/Library/Logs/Homebrew/gazebo11/02.make:

error incompatible with your Protocol Buffer headers. Please

^ /usr/local/include/ignition/msgs5/ignition/msgs/material.pb.h:19:2: error: regenerate this file with a newer version of protoc.

error regenerate this file with a newer version of protoc.

^ /usr/local/include/ignition/msgs5/ignition/msgs/material.pb.h:62:51: error: no type named 'AuxillaryParseTableField' in namespace 'google::protobuf::internal'; did you mean 'AuxiliaryParseTableField'? static const ::PROTOBUF_NAMESPACE_ID::internal::AuxillaryParseTableField aux[] ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^ /usr/local/include/google/protobuf/generated_message_table_driven.h:141:7: note: 'AuxiliaryParseTableField' declared here union AuxiliaryParseTableField { ^ 16 errors generated. make[2]: * [gazebo/msgs/CMakeFiles/gazebo_msgs.dir/msgs.cc.o] Error 1 make[1]: [gazebo/msgs/CMakeFiles/gazebo_msgs.dir/all] Error 2 make: ** [all] Error 2

If reporting this issue please do so at (not Homebrew/brew or Homebrew/core): https://github.com/osrf/homebrew-simu...

These open issues may also help: Installing gazebo11 on iMac fails https://github.com/osrf/homebrew-simu...

edit retag flag offensive close merge delete