Gazebo does not launch when entering the launch command 2020

asked 2020-09-04 08:42:38 -0600

Elias gravatar image

Hi,

This question was asked before, but the proposed solutions are not working with me.

from the "Using Open AI with ROS" Article, i am trying to launch the simulation and the training of the parrot drone locally, on my PC.

I am using ROS kinetic + gazebo 7

I managed to download all the scripts and files, and i ran them, the training was happening, all the topics were published and it partially worked, except that the gazebo simulation did not open (gazebo did not launch). However, the Rviz worked and showed the camera frames but crashed after a short while:

in rviz: camera frames showed that the drone was navigating before it crashes a short after. The robot model did not appear

rviz camera frame working

rviz camera frame not working

image description

here is my code of launching the simulation:

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

!/bin/sh

find where the 'sjtu_drone' is

pack_path=$(rospack find sjtu_drone)

export the gazebo pathes

export GAZEBO_MODEL_PATH=$pack_path/models:$GAZEBO_MODEL_PATH export GAZEBO_RESOURCE_PATH=$pack_path:/usr/share/gazebo-3.0:/usr/share/gazebo-4.0:/usr/share/gazebo_models:$GAZEBO_RESOURCE_PATH export GAZEBO_PLUGIN_PATH=$pack_path/plugins:$GAZEBO_PLUGIN_PATH

call the client of Gazebo

roslaunch drone_construct main.launch gui:=true paused:=false

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

can i get any help on how to run the gazebo simulation and how to see all the models in Rviz?

Thanks

edit retag flag offensive close merge delete