How to stop gzclient from updating the database during startup?

asked 2020-09-08 02:50:23 -0500

NikolasE gravatar image

Hey!

I installed gazebo 11.1.0 with ros2-foxy and have an issue with the way it starts:

gzclient --verbose

Gazebo multi-robot simulator, version 11.1.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 10.1.2.3
[Wrn] [Event.cc:61] Warning: Deleting a connection right after creation. Make sure to save the ConnectionPtr from a Connect call
[Msg] Waiting for model database update to complete...

This takes around 30 seconds every time I start the client. I used wireshark to check what's going on and gzclient is talking to https://models.gazebosim.org and creates a HTTP connection for every model. Is there a way to either speed this up or better yet, completely disable this function?

edit retag flag offensive close merge delete