Gazebo | Ignition | Community
Ask Your Question
0

FrameAttachedToGraph error when spawning robot from URDF

asked 2020-11-03 01:49:10 -0500

dondel gravatar image

Hello,

I am trying to spawn franka emika panda's arm and hand (or even just the arm) from gazebo_ros spawn model, but the scene stays empty, the model list on the left part of the gui lists the name of my model but without any child and I get this error :

[Err] [Model.cc:99] Error Code 23 Msg: FrameAttachedToGraph error, Non-LINK vertex with name [__model__] is disconnected; it should have 1 outgoing edge in MODEL attached_to graph. [Err] [Model.cc:99] Error Code 23 Msg: Graph has __model__ scope but sink vertex named [__model__] does not have FrameType LINK when starting from vertex with name [__model__]. I can trace back this error to the validateFrameAttachedToGraph function of FrameSemantics.cc in the sdfFromat library but I have no idea how to solve that. I don't think my urdf is broken, it's the urdf.xacro file from franka_ros. Has anyone ever encountered this issue ?

I am using Gazebo 11.1.0 with Ros Noetic on Ubuntu 20.04.1

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-06 02:53:32 -0500

dondel gravatar image

See https://github.com/osrf/gazebo/issues/2869

sdf ignores links without intertia

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-11-03 01:49:10 -0500

Seen: 306 times

Last updated: Nov 06 '20