animated model (actor) is invisible due to (maybe) a SSL problem

asked 2020-11-09 08:24:22 -0500

Idontwan gravatar image

updated 2020-11-10 10:56:34 -0500

I have developed a software which can produce Gazebo scenario files automatically. The produced files call the actor module (http://gazebosim.org/tutorials?tut=ac...). The files has been tested a month ago, the actor module was called successfully, I saw a walking human. When I ran these file today, the walking human disappear, but everything else is correct.

I do some test:

If I run the gazebo-11/worlds/actor.world or /actor_bvh.world, I can't see anything. The actor module is not appear, and the terminal warn:

libcurl: (35) SSL: couldn't get X509-issuer name!

So, I think my files are correct and my Gazebo has a SSL problem. How can I fix it?

Update:

I do a test today. I choose to follow the actor. The view did follow its trajectory, but I can't see the actor model.

Then I reinstall Gazebo 11. This problem is still existed. I run the famous cafe.world (https://www.youtube.com/watch?v=nZN07...), the two actors are invisible, but everything else is correct. image description

When I click the actor1_plugin, the terminal warn:

Topic [/data://world/default/model/actor1/plugin/actor1_plugin/joint_cmd] is not valid.

edit retag flag offensive close merge delete