Gazebo | Ignition | Community
Ask Your Question
0

Problem importing Textured Model actor from Blender

asked 2020-12-10 12:00:00 -0500

Domi gravatar image

Hello guys, I'm trying to create a human model for using it as an actor in Gazebo 9. I create the model in MakeHuman and export it as a .dae file to import it in Blender as many tutorials do (https://www.youtube.com/watch?v=7kEmT...). But doing the same, my model doesn't load the textures.

The thing is many tutorials use old versions of Blender that have different options when exporting a .dae, like 'Include Material Textures' and 'UV Textures' . Still I have installed and old version such as Blender 2.78 that has those options but still, textures doesn't work in gazebo.

image description

In the past I have used SketchUp for texturing some buildings but this time, working with human models I can't avoid to use Blender. I have other human models I took from the web that load the textures perfectly such as person_standing.dae or person_walking.dae and reading those files a little bit you can see they were created with Blender (2.73). So the problem must be in the .dae creation.

I would appreciate any help with this. Thank you!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-12-10 20:40:31 -0500

wongrufus gravatar image

updated 2020-12-16 19:50:52 -0500

See this answer.

From the screenshot, it seems the texture is loaded, just that it's too dark. Try adjusting the <ambient> value in the .dae file

You may also want to double check the <init_from> tags to make sure the texture image paths are correct. It must be relative to the .dae file's location.

edit flag offensive delete link more

Comments

For me, setting the <ambient>r g b a</ambient> to the same value as the <diffuse>r g b a</diffuse> fixed the issue.

Versions: Gazebo 11 and Blender 2.79b

JakobThumm gravatar imageJakobThumm ( 2021-05-19 02:57:07 -0500 )edit
0

answered 2020-12-16 07:53:58 -0500

Domi gravatar image

updated 2020-12-16 08:06:14 -0500

Thank you very much @wrongrufus. Setting the <ambient> to an appropriate value actually improve the darkness, but still the materials seems not to work:

image description

When the real model created from MakeHuman is as following:

image description

I've been doing some tests and I found that the problem is on the model exported with an skeleton from MakeHuman (Cmu mb). I have created a new model an exported with and without skeleton. Then in Blender i have followed the same steps for both. Then in Gazebo I got this, the models with skeleton seem to have problems with materials:

image description

Did anyone create textured model for working as actors (with skeleton)? The examples I saw online for actor use always the same dummy, that I'm not sure if it has materials:

image description

Is it maybe a known problem about actors in Gazebo??

edit flag offensive delete link more

Comments

I've been able to do it using the Cmu mb rig. When exporting the model from Blender, make sure you are exporting to another directory and use the copy option so that Blender exports the proper textures as well.

On another note, I think that you should update your question or create a new question instead of posting it as an answer. This is not a forum, so answers are ordered by their vote count, not by their post order. You should use comments to discuss a given answer.

Silas Alves gravatar imageSilas Alves ( 2020-12-16 11:06:55 -0500 )edit

Glad I could help, pertaining to proper Q&A etiquette, it is preferable to edit the question directly if you have additional information to provide instead of posting the additional information as an answer. That said, I've edited my answer after considering the new information. See if that helps

wongrufus gravatar imagewongrufus ( 2020-12-16 19:52:53 -0500 )edit

Thank you Silas Alves and wongrufus, and sorry about creating a new question, I didn't know ho to do it. I will do it better next time. I have tried several times, I checked the texture path were the appropriate ones, also the <ambient>. I tried using Copy and a new directory. But it is still always the same, if I do without skeleton everything is fine, but doing the same steps for a model with skeleton always lead to a model without materials.

Domi gravatar imageDomi ( 2020-12-23 05:59:16 -0500 )edit

Am I maybe missing any option when importing or exporting the skeleton? (from MakeHuman or Blender)

Silas Alves, do you have any textured actor shared throw github maybe? so I can test it.

Thank you!

Domi gravatar imageDomi ( 2020-12-23 06:02:15 -0500 )edit

You can prolly check the gazebo_models repo which has lots of examples of models with textures / materials.

wongrufus gravatar imagewongrufus ( 2020-12-29 20:17:31 -0500 )edit

You can prolly check the gazebo_models repo which has lots of examples of models with textures / materials.

wongrufus gravatar imagewongrufus ( 2020-12-29 20:17:47 -0500 )edit

I have checked the repo and I don't see any model with skeleton there. I have used many textured models in gazebo without any problem. My problem is just when importing textured actors, that is human models with skeleton

Domi gravatar imageDomi ( 2021-01-08 04:50:11 -0500 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2020-12-10 12:00:00 -0500

Seen: 174 times

Last updated: Dec 16 '20