Gazebo | Ignition | Community
Ask Your Question
0

Does anyone know how to allow my virtual machine to run gazebo version 9 without unticking accelerate 3D graphics?

asked 2021-01-06 13:36:46 -0500

Hello,

My system is a ubuntu 18.04.5 virtual machine being run off VMWare workstation 16 player. I have download gazebo 9 with ROS melodic. Everytime I try to load gazebo I get this error:

VMware: vmw_ioctl_command error Invalid argument.

I have scoured other peopels forums for solutions on this and the two solutions people ususualy give are either 1- turn off accelerate 3D graphics option on the VMWARE settings - this does fix the issue however gazebo runs very slowly then and I am looking for a better solution. 2 - run this command in your bash rc to downgrade the OPENL GL version: "export SVGA_VGPU10=0" - this appears to have no effect for solving this issue despite other people saying it works for them. I have no idea why not.

If anyone has any ideas I would greatly appreciate hearing them

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-01-07 06:13:47 -0500

My issue appears to have fixed itself for the most part, there seems to be a weird interaction where you cant run gazebo as a sudo user but if you run it normally it works fine, I was only testing it by trying to run it as a super user. However this does pose a new problem that I will have to face eventually which is that I cant save new maps on gazebo unless I am a super user. Hopefully there is a way to save maps without being a super user.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-06 13:36:46 -0500

Seen: 38 times

Last updated: Jan 07