Gazebo | Ignition | Community
Ask Your Question
0

No shadows or light in image of camera sensor and low fps in gazebo

asked 2021-01-13 11:58:23 -0600

Zeckurbo gravatar image

I wanted to display an office in gazebo 11. I added some light to make it look better, but so far it seems like the light does not affect the camera sensor.

image description

Also my fps in the editor is very low (lower than 1 fps).

image description

Does anyone know what could cause that or how I can add shadow display to the camera sensor and increase the fps in the editor?

edit retag flag offensive close merge delete

Comments

As it seems the problem of the low fps was because of my virtual machine. I tried a real linux and now it works fine

Zeckurbo gravatar imageZeckurbo ( 2021-01-14 13:32:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-01-13 22:33:10 -0600

Veerachart gravatar image

Does your simulation has a depth camera included? I had similar problem before that the depth camera disabled the lighting in RGB camera.

If this is the case, I solved it by setting <always_on>false</always_on> to the depth camera. Then after you start the simulation, enable the camera (by the Topic Visualization, or a sensor plugin).

For the FPS, there are quite a few factors: the size, number, and complexity of the environment meshes; your GPU sensors' resolutions (cameras, lidars); the lights.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-13 11:58:23 -0600

Seen: 26 times

Last updated: Jan 13