Gazebo | Ignition | Community
Ask Your Question
0

gazebo ardupilot plugin compilation error

asked 2021-01-19 07:48:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everyone !

I deleted gazebo, gazebo_ardupilot and ros for some reason I worked on before. I recently reinstalled gazebo version 9. In addition, I want to install the gazebo_ardupilot plugin.

cd ~
git clone https://github.com/khancyr/ardupilot_gazebo.git
cd ardupilot_gazebo
git checkout dev
mkdir build
cd build

I'm proceeding smoothly up to the codes above. However, when I run the code "cmake .." I get the following error.

~/ardupilot_gazebo/build$ cmake ..

CMake Error at CMakeLists.txt:11 (find_package):
  By not providing "Findgazebo.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "gazebo", but
  CMake did not find one.

  Could not find a package configuration file provided by "gazebo" with any
  of the following names:

    gazeboConfig.cmake
    gazebo-config.cmake

  Add the installation prefix of "gazebo" to CMAKE_PREFIX_PATH or set
  "gazebo_DIR" to a directory containing one of the above files.  If "gazebo"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!
See also "/home/omer/ardupilot_gazebo/build/CMakeFiles/CMakeOutput.log".

I also added the log file in case you want to look. Here you are

CmakeOutputLog

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-02-15 02:26:11 -0500

ahcorde gravatar image

Hello,

you should install Gazebo dev files. sudo apt-get install libgazebo9-dev and then try again.

Regards

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-19 07:48:46 -0500

Seen: 16 times

Last updated: Feb 15