Unable to load prebuild world-file

asked 2021-01-20 03:07:28 -0600

morrac gravatar image

Hello guys,

recently I tried to start the world "office_small.world" out of this collection: https://github.com/chaolmu/gazebo_mod...

While starting this world I'm getting this error message, I don't really understand.

gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:734: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::rendering::Camera; typename boost::detail::sp_member_access<T>::type = gazebo::rendering::Camera*]: Zusicherung »px != 0« nicht erfüllt.

As written in the read.me file I added these lines into the ~/.bashrc-file:

export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:~/gazebo_models_worlds_collection-master/models
export GAZEBO_RESOURCE_PATH=$GAZEBO_RESOURCE_PATH:~/gazebo_models_worlds_collection-master/worlds

I'm using Ubuntu 20.04.1 LTS with Gazebo 11 installed. Before using it on my main system I tested these worlds on a Virtual Machine running Ubuntu and it worked there.

edit retag flag offensive close merge delete

Comments

I found out that this Error also pops up, when I try to load a self build world with the command: gazebo example.world

If I use this command: sudo gazebo example.world The world open properly.

In case of the model and world collection the the world at least opens when I start gazebo with sudo. The problem then is, that the textures and models don't get loaded.

morrac gravatar imagemorrac ( 2021-01-25 05:13:35 -0600 )edit