Gazebo | Ignition | Community
Ask Your Question

SDF model not loading properly in ignition gazebo

asked 2021-01-25 10:02:18 -0500

Paal gravatar image

updated 2021-01-31 09:01:51 -0500


So I've run into the problem of loading my robot to ignition gazebo. I find the issue rather weird as I am able to load my model perfectly fine in gazebo classic, and when importing the model into ignition gazebo through the GUI it also works. However, when launching using either launch files, or via world files, the only thing that seems to load is a number of green plates (see illustration). image description

I believe the issue lies within the models sdf file but with numerous attempts I still struggle with solving the issue so therefore I wonder if anyone has experienced this before and has some suggestions on how to sovle the issue at hand?

The code can be found here:

where the robot model lies within the tetrapod_description package. A world file can be found under tetrapod_ignition/worlds for ignition gazebo (and under tetrapod_gazebo/worlds for gazebo classic if interested). Usually i run the simulation using:

ign gazebo tetrapod_world.sdf

If any additional information is needed for a better understanding of the problem, please don't hesitate to let me know.


Update: I've also tried with the following model from fuel ignition:

where the same issue arose.

edit retag flag offensive close merge delete


Strange Meshes can often be traced back to a locale problem, i.e., the machine using commas instead of dots to represent decimals. Check ign-rendering#136 for some details. As a workaround, you can try to set the locale of your system to US to see if that fixes the problem. I also cloned your repo and tried to open the world; I am seeing errors for invalid inertia.

FirefoxMetzger gravatar imageFirefoxMetzger ( 2021-03-19 14:34:11 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2021-02-02 23:04:01 -0500

azeey gravatar image

I think it might be having problems locating the included model in the world file. Included resources are handled differently in ign-gazebo (see for details). Setting IGN_GAZEBO_RESOURCE_PATH to the directory containing tetrapod_description fixed the issue for me.

Running ign gazebo with -v 4 might show some helpful information.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2021-01-25 10:02:18 -0500

Seen: 975 times

Last updated: Feb 02 '21