SetWorldPose with ODE works but fails in DART

asked 2021-01-25 12:06:52 -0600

trns1997 gravatar image

Hey guys, I have the following issue. I wrote a plugin that basically sets link poses in the world. For some reason it works when the engine is set to ode and fails when i run it using the dart engine. So when I run my world file using gazebo --verbose simulation.world the link SetWorldPose works:

I check if the correct physics engine is running, i have a print that outputs the following:

[Plugin] Using Physcis Engine: ode

Gazebo ODE Output:

(You can ignore the weird pose it is not important.)

Working with ODE

But When I run using DART, with the following command gazebo --verbose -e dart simulation.world

The print statement to check if dart is used:

[Plugin] Using Physcis Engine: dart

Gazebo DART Output

Not Working With Dart

Here you can find all the code: https://github.com/trns1997/GazeboDar...

I just do not get why the SetWorldPose does not work when I use dart and works with ode. Hope someone can help me out with this issue.

edit retag flag offensive close merge delete

Comments

I have found a work around. Set the root link pose and the setJointPosition did the trick. But I would still like to know why setting link pose does not work when you switch from one engine to the other.

trns1997 gravatar imagetrns1997 ( 2021-01-27 07:14:34 -0600 )edit