Flickering Depth Camera image inside Gazebo Topic Visualization

asked 2021-01-27 08:05:16 -0600

morrac gravatar image

updated 2021-01-29 02:39:38 -0600

Hey,

I experienced a strange flickering when I simulated a depth camera in Gazebo. I tried both Openni Kinect and libDepthCamera. Both of them are having the same Error.

image description

image description

The camera is placed on top of a unit box. The second one is the desired picture and I have no clue why this is happening

Thanks for your help! Update: Used Files World File C:\fakepath\myrobot.world

Gazebo File C:\fakepath\myrobot_gazebo.sdf

Xacro File C:\fakepath\myrobot_xacro.sdf

edit retag flag offensive close merge delete

Comments

Can you post your world file, the command you used to run Gazebo, and your version of Gazebo?

nkoenig gravatar imagenkoenig ( 2021-01-27 08:08:54 -0600 )edit

I've uploaded the world-File :)

I am using Gazebo 11.1.0.

I use roslaunch myrobot_gazebo myrobot.launch to run Gazebo

morrac gravatar imagemorrac ( 2021-01-28 11:32:29 -0600 )edit

I think your camera sensor specification must be in your myrobot. I don't see a camera sensor in your world file.

nkoenig gravatar imagenkoenig ( 2021-01-28 13:17:09 -0600 )edit

I updloaded the gazebo and xacro files where I specified the use of the camera :)

morrac gravatar imagemorrac ( 2021-01-29 02:41:22 -0600 )edit